Skocz do zawartości
radekd2

Historia pojazdu - wydruk danych.

Rekomendowane odpowiedzi

radekd2

Cześć,

podczas wykonywania BT mogę podejrzeć dane z historiapojazdu.gov.pl. Po pobraniu danych chce je wydrukować ale podgląd wydruku otwiera się w przeglądarce IE i wszystkie pola są puste. W załączeniu przykład.

Nie wiem gdzie tkwi błąd. Czy IE nie potrafi wyświetlić prawidłowo pdf? Jeżeli tak to jak zmienić w StacjiSQL domyślną przeglądarkę?

Pozdr. R.

przykład.pdf

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach
cezary

A jak ustawisz którąś inną przeglądarkę jako domyślną to nie wystarczy? 

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach
radekd2

Domyślną w systemie jest FF, a i tak StacjaSQL otwiera pdfa w IE.

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach
IVVO

Bo masz 10 - historia jest w pdf - trzeba ustawić w systemie aby pdf otwierał i pobierał AR - domyślnie po aktualizacji robi to IE

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach
radekd2

Mam Windows 7 i w systemie mam ustawione, iż domyślnie pdfy otwierane są przez AR.

TYLKO StacjaSQL otwiera je przez IE :(

EDIT:

Uściślę problem:
W badaniu technicznym po kliknięciu na przycisk "Historia - CEPiK" otwiera się okno z danymi pojazdu. U mnie jest to okno programu Internet Explorer. Dane są wyświetlane prawidłowo.
W tym oknie klikam na "Pobierz PDF". Pobrany pdf otwiera się w kolejnym oknie programu IE jest on już nieprawidłowo wyświetlany - bez danych pojazdu. Jak w załączniku na początku.

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach
danielg539
1 godzinę temu, radekd2 napisał:

U mnie jest to okno programu Internet Explorer

U mnie okno programu AR i drukuje się poprawnie. Zapewne trzeba coś zmienić w ustawieniach programu.

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach
Yeti

Spróbuj w ten sposób, zaznacz cokolwiek następnie naciśnij na zaznaczonym prawy klawisz , wybierz "Drukuj"  jak nie wybierzesz drukuj zaznaczone to wydrukuje Ci wszystko.

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach
radekd2
17 godzin temu, danielg539 napisał:

U mnie okno programu AR i drukuje się poprawnie. Zapewne trzeba coś zmienić w ustawieniach programu.

Tylko co zmienić?

17 godzin temu, Yeti napisał:

Spróbuj w ten sposób, zaznacz cokolwiek następnie naciśnij na zaznaczonym prawy klawisz , wybierz "Drukuj"  jak nie wybierzesz drukuj zaznaczone to wydrukuje Ci wszystko.

Ale wtedy drukuje stronę internetową, a mi chodzi o pobranie i wydruk oficjalnego raportu z CEPiK.

Chyba będę musiał poprosić o pomoc Pana Norberta.

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach
Paprock

A na co to komu? Po co to drukować komu? Klientowi? A z jakiej racji?

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach
yatsek
Napisano (edytowane)
19 godzin temu, Yeti napisał:

Spróbuj w ten sposób, zaznacz cokolwiek następnie naciśnij na zaznaczonym prawy klawisz , wybierz "Drukuj"  jak nie wybierzesz drukuj zaznaczone to wydrukuje Ci wszystko.

Właśnie, tak ja też robię i drukuje wszystko. Mi "strony internetowej" nie drukuje mam sam raport.

Edytowane przez yatsek

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach
radekd2

Mi drukuje stronę internetową.

Teraz robię tak:
Klikam prawym klawiszem myszy na przycisk "Pobierz PDF" i wybieram z menu "Zapisz element docelowy jako..." i teraz pobrany pdf jest OK. Trochę pokręcone ale działa :)

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach
danielg539
50 minut temu, radekd2 napisał:

klawiszem myszy na przycisk "Pobierz PDF" i wybieram z menu "Zapisz element docelowy jako..." i teraz pobrany pdf jest OK

To chyba taka przypadłość nowszych wersji Windowsa i aby coś wydrukować trzeba to zapisać, bo drukowanie z podglądu zmienia formatowanie i albo coś ucina albo drukuje z widokiem oka przeglądarki.

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach
radekd2
2 minuty temu, danielg539 napisał:

To chyba taka przypadłość nowszych wersji Windowsa

Jak napisałem wcześniej mam Windows 7 więc nie można mówić, iż jest to nowsza wersja :)

Długi czas działało wszystko OK. Jak dobrze pamiętam, to dopiero od kilku miesięcy mam ten problem.

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach
danielg539

Pewnie jakaś aktualizacja zmieniła ustawienia. Na Win7 ten problem z drukowanie tez występował.

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

Dołącz do dyskusji

Możesz dodać zawartość już teraz a zarejestrować się później. Jeśli posiadasz już konto, zaloguj się aby dodać zawartość za jego pomocą.

Gość
Dodaj odpowiedź do tematu...

×   Wklejono zawartość z formatowaniem.   Usuń formatowanie

  Dozwolonych jest tylko 75 emoji.

×   Odnośnik został automatycznie osadzony.   Przywróć wyświetlanie jako odnośnik

×   Przywrócono poprzednią zawartość.   Wyczyść edytor

×   Nie możesz bezpośrednio wkleić grafiki. Dodaj lub załącz grafiki z adresu URL.


×
×
  • Dodaj nową pozycję...

Powiadomienie o plikach cookie

Umieściliśmy na Twoim urządzeniu pliki cookie, aby pomóc Ci usprawnić przeglądanie strony. Możesz dostosować ustawienia plików cookie, w przeciwnym wypadku zakładamy, że wyrażasz na to zgodę.